summaryrefslogtreecommitdiffstats
path: root/lib/AST/CMakeLists.txt
diff options
context:
space:
mode:
authorJeffrey Yasskin <jyasskin@google.com>2011-02-11 23:46:38 +0000
committerJeffrey Yasskin <jyasskin@google.com>2011-02-11 23:46:38 +0000
commit0a86d44703fc5cd3cd38ea1708176f5b44321ed8 (patch)
tree78e022ccebc6e4e69d34ecf4b50afcb5c1ed8ee2 /lib/AST/CMakeLists.txt
parent848ec83483ca4ba52ed72c7e29ebc330f8c87252 (diff)
Add CMake dependencies so that LLVM_USED_LIBS order doesn't matter.
I also sorted the tools/driver dependencies since their order no longer matters. git-svn-id: https://llvm.org/svn/llvm-project/cfe/trunk@125417 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/AST/CMakeLists.txt')
-rw-r--r--lib/AST/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/lib/AST/CMakeLists.txt b/lib/AST/CMakeLists.txt
index e767ebcb3a..9fe18407a8 100644
--- a/lib/AST/CMakeLists.txt
+++ b/lib/AST/CMakeLists.txt
@@ -1,3 +1,5 @@
+set(LLVM_LINK_COMPONENTS support)
+
set(LLVM_USED_LIBS clangBasic)
add_clang_library(clangAST