summaryrefslogtreecommitdiffstats
path: root/lib/AST/CMakeLists.txt
diff options
context:
space:
mode:
authorDouglas Gregor <dgregor@apple.com>2010-02-05 17:54:41 +0000
committerDouglas Gregor <dgregor@apple.com>2010-02-05 17:54:41 +0000
commit1b2949d27ec72894dec017c330c0548af4bb2476 (patch)
treed4ee0dc7d9c8cc1972f56d3c8af05c528cfbef00 /lib/AST/CMakeLists.txt
parentf1e57ada1f48d70b9bb9b2585be1644baf534907 (diff)
Initial skeleton of an AST "importer", which will take AST elements from
one context and import them into another context, merging them according to language-specific rules. This is a skeleton. It doesn't work, it isn't testable, but I want it in version control. git-svn-id: https://llvm.org/svn/llvm-project/cfe/trunk@95395 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/AST/CMakeLists.txt')
-rw-r--r--lib/AST/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/lib/AST/CMakeLists.txt b/lib/AST/CMakeLists.txt
index dea96e7866..364f7a5ecd 100644
--- a/lib/AST/CMakeLists.txt
+++ b/lib/AST/CMakeLists.txt
@@ -4,6 +4,7 @@ add_clang_library(clangAST
APValue.cpp
ASTConsumer.cpp
ASTContext.cpp
+ ASTImporter.cpp
AttrImpl.cpp
CXXInheritance.cpp
Decl.cpp