summaryrefslogtreecommitdiffstats
path: root/lib/AST/CMakeLists.txt
diff options
context:
space:
mode:
authorArgyrios Kyrtzidis <akyrtzi@gmail.com>2009-07-05 22:22:06 +0000
committerArgyrios Kyrtzidis <akyrtzi@gmail.com>2009-07-05 22:22:06 +0000
commit2c2ba3e258961dd98cacffe3a2167bb6d958fd53 (patch)
tree33e173c8ed6f33bf8d468749ce95e2d4fefcfa71 /lib/AST/CMakeLists.txt
parentfc7e2a8fbb08f0f496ac6cea0721fe72db8ce240 (diff)
Introduce the DeclReferenceMap class inside the AST library.
DeclReferenceMap (similar to ParentMap) is a helper class for mapping Decls to the AST nodes that reference them. A client will initialize it by passing an ASTContext to its constructor and later use it to iterate over the references of a Decl. References are mapped and retrieved using the primary declaration (Decl::getPrimaryDecl()) of a particular Decl. git-svn-id: https://llvm.org/svn/llvm-project/cfe/trunk@74801 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/AST/CMakeLists.txt')
-rw-r--r--lib/AST/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/lib/AST/CMakeLists.txt b/lib/AST/CMakeLists.txt
index 8fb86c6fc2..899bc8f78e 100644
--- a/lib/AST/CMakeLists.txt
+++ b/lib/AST/CMakeLists.txt
@@ -13,6 +13,7 @@ add_clang_library(clangAST
DeclGroup.cpp
DeclObjC.cpp
DeclPrinter.cpp
+ DeclReferenceMap.cpp
DeclTemplate.cpp
ExprConstant.cpp
Expr.cpp