summaryrefslogtreecommitdiffstats
path: root/lib/AST/CMakeLists.txt
diff options
context:
space:
mode:
authorDouglas Gregor <dgregor@apple.com>2009-05-30 00:08:05 +0000
committerDouglas Gregor <dgregor@apple.com>2009-05-30 00:08:05 +0000
commit4fe0c8e9c76b96e7aff21696a40dacc09d0237bc (patch)
tree1b4253035fcbb699c4110f220609fc7f37e64ca0 /lib/AST/CMakeLists.txt
parent9e8a72291465488e734c8aa5e20142d8b3cd981c (diff)
Refactor and clean up the AST printer, so that it uses a DeclVisitor,
walks through DeclContexts properly, and prints more of the information available in the AST. The functionality is still available via -ast-print, -ast-dump, etc., and also via the new member functions Decl::dump() and Decl::print(). git-svn-id: https://llvm.org/svn/llvm-project/cfe/trunk@72597 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/AST/CMakeLists.txt')
-rw-r--r--lib/AST/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/lib/AST/CMakeLists.txt b/lib/AST/CMakeLists.txt
index a282f202f2..19ab9f650e 100644
--- a/lib/AST/CMakeLists.txt
+++ b/lib/AST/CMakeLists.txt
@@ -12,6 +12,7 @@ add_clang_library(clangAST
DeclCXX.cpp
DeclGroup.cpp
DeclObjC.cpp
+ DeclPrinter.cpp
DeclTemplate.cpp
ExprConstant.cpp
Expr.cpp