summaryrefslogtreecommitdiffstats
path: root/lib/AST/CMakeLists.txt
diff options
context:
space:
mode:
authorTed Kremenek <kremenek@apple.com>2010-03-08 20:56:29 +0000
committerTed Kremenek <kremenek@apple.com>2010-03-08 20:56:29 +0000
commit503524acc73f2f8280080ca0d200377406001b65 (patch)
treee366fb5c08f328117a06c12b56b3733acb7569ae /lib/AST/CMakeLists.txt
parent0804e6e0ad2862826497677a4c26c6a9d7c3d66c (diff)
Allocate ASTRecordLayout objects using the allocator associated with ASTContext.
This allows them to be allocated using a BumpPtrAllocated in the common case. git-svn-id: https://llvm.org/svn/llvm-project/cfe/trunk@97978 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/AST/CMakeLists.txt')
-rw-r--r--lib/AST/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/lib/AST/CMakeLists.txt b/lib/AST/CMakeLists.txt
index e5bd9b7722..2f1a6af77a 100644
--- a/lib/AST/CMakeLists.txt
+++ b/lib/AST/CMakeLists.txt
@@ -4,8 +4,8 @@ add_clang_library(clangAST
APValue.cpp
ASTConsumer.cpp
ASTContext.cpp
- ASTImporter.cpp
ASTDiagnostic.cpp
+ ASTImporter.cpp
AttrImpl.cpp
CXXInheritance.cpp
Decl.cpp
@@ -23,6 +23,7 @@ add_clang_library(clangAST
InheritViz.cpp
NestedNameSpecifier.cpp
ParentMap.cpp
+ RecordLayout.cpp
RecordLayoutBuilder.cpp
Stmt.cpp
StmtDumper.cpp