summaryrefslogtreecommitdiffstats
path: root/lib/AST/CMakeLists.txt
diff options
context:
space:
mode:
authorDouglas Gregor <dgregor@apple.com>2010-02-09 22:26:47 +0000
committerDouglas Gregor <dgregor@apple.com>2010-02-09 22:26:47 +0000
commit79a9a3417929e340e84dcbc06ed9c3a277cad959 (patch)
treea3f50e70a16c265f5d7c4eb703d4e84482f43d85 /lib/AST/CMakeLists.txt
parent41e9066e3f8b46fa10fb868b86a2c9a54526816c (diff)
Move the diagnostic argument formatting function out of Sema and make
it available within the AST library, of which Sema is one client. No functionality change. git-svn-id: https://llvm.org/svn/llvm-project/cfe/trunk@95701 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/AST/CMakeLists.txt')
-rw-r--r--lib/AST/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/lib/AST/CMakeLists.txt b/lib/AST/CMakeLists.txt
index 364f7a5ecd..e5bd9b7722 100644
--- a/lib/AST/CMakeLists.txt
+++ b/lib/AST/CMakeLists.txt
@@ -5,6 +5,7 @@ add_clang_library(clangAST
ASTConsumer.cpp
ASTContext.cpp
ASTImporter.cpp
+ ASTDiagnostic.cpp
AttrImpl.cpp
CXXInheritance.cpp
Decl.cpp