summaryrefslogtreecommitdiffstats
path: root/lib/AST/CMakeLists.txt
diff options
context:
space:
mode:
authorArgyrios Kyrtzidis <akyrtzi@gmail.com>2009-07-05 22:21:28 +0000
committerArgyrios Kyrtzidis <akyrtzi@gmail.com>2009-07-05 22:21:28 +0000
commitc0824634334ff0bb66cf8fb260101a5faaebf4b7 (patch)
tree8fac3c61995f970032a9025d263c3ce15cfc0327 /lib/AST/CMakeLists.txt
parent685477f910901e57b2441981c3bd3d5b9c0f228d (diff)
Introduce ASTNode class into the AST library.
ASTNode is an immutable pair of a Decl and Stmt. If Stmt is not null, Decl should be its immediate parent. git-svn-id: https://llvm.org/svn/llvm-project/cfe/trunk@74797 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/AST/CMakeLists.txt')
-rw-r--r--lib/AST/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/lib/AST/CMakeLists.txt b/lib/AST/CMakeLists.txt
index ac4cbb2d29..8fb86c6fc2 100644
--- a/lib/AST/CMakeLists.txt
+++ b/lib/AST/CMakeLists.txt
@@ -4,6 +4,7 @@ add_clang_library(clangAST
APValue.cpp
ASTConsumer.cpp
ASTContext.cpp
+ ASTNode.cpp
CFG.cpp
DeclarationName.cpp
DeclBase.cpp