summaryrefslogtreecommitdiffstats
path: root/lib/Analysis/CMakeLists.txt
diff options
context:
space:
mode:
authorAnna Zaks <ganna@apple.com>2012-03-08 00:42:23 +0000
committerAnna Zaks <ganna@apple.com>2012-03-08 00:42:23 +0000
commit196b8cfe9cfcc452eb2f83aa4ad330c2324f8c7d (patch)
treeea3a4db00450824ae99c91aabe9dddb2aad8b84d /lib/Analysis/CMakeLists.txt
parenta34194f035096dd8dce10574e3a186da968aa211 (diff)
Add a basic CallGraph to Analysis.
The final graph contains a single root node, which is a parent of all externally available functions(and 'main'). As well as a list of Parentless/Unreachable functions, which are either truly unreachable or are unreachable due to our analyses imprecision. The analyzer checkers debug.DumpCallGraph or debug.ViewGraph can be used to look at the produced graph. Currently, the graph is not very precise, for example, it entirely skips edges resulted from ObjC method calls. git-svn-id: https://llvm.org/svn/llvm-project/cfe/trunk@152272 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/Analysis/CMakeLists.txt')
-rw-r--r--lib/Analysis/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/lib/Analysis/CMakeLists.txt b/lib/Analysis/CMakeLists.txt
index 4b88ad279a..43c3ffbaf1 100644
--- a/lib/Analysis/CMakeLists.txt
+++ b/lib/Analysis/CMakeLists.txt
@@ -2,6 +2,7 @@ set(LLVM_USED_LIBS clangBasic clangAST clangIndex)
add_clang_library(clangAnalysis
AnalysisDeclContext.cpp
+ CallGraph.cpp
CFG.cpp
CFGReachabilityAnalysis.cpp
CFGStmtMap.cpp