summaryrefslogtreecommitdiffstats
path: root/lib/Basic/CMakeLists.txt
diff options
context:
space:
mode:
authorSaleem Abdulrasool <compnerd@compnerd.org>2016-04-07 17:49:44 +0000
committerSaleem Abdulrasool <compnerd@compnerd.org>2016-04-07 17:49:44 +0000
commit8cca4d7cdf58cac30a9e273dc5d7b5d9c9189bb6 (patch)
treef39bc01cc80139c0d2df890b13873918f2711e24 /lib/Basic/CMakeLists.txt
parent5cfb9ae98edba88089fe3321b3701d3750a5b191 (diff)
Basic: move CodeGenOptions from Frontend
This is a mechanical move of CodeGenOptions from libFrontend to libBasic. This fixes the layering violation introduced earlier by threading CodeGenOptions into TargetInfo. It should also fix the modules based self-hosting builds. NFC. git-svn-id: https://llvm.org/svn/llvm-project/cfe/trunk@265702 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/Basic/CMakeLists.txt')
-rw-r--r--lib/Basic/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/lib/Basic/CMakeLists.txt b/lib/Basic/CMakeLists.txt
index cfad8c3649..8eff9fd5af 100644
--- a/lib/Basic/CMakeLists.txt
+++ b/lib/Basic/CMakeLists.txt
@@ -59,6 +59,7 @@ add_clang_library(clangBasic
Attributes.cpp
Builtins.cpp
CharInfo.cpp
+ CodeGenOptions.cpp
Diagnostic.cpp
DiagnosticIDs.cpp
DiagnosticOptions.cpp