summaryrefslogtreecommitdiffstats
path: root/lib/Driver/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexey Samsonov <vonosmas@gmail.com>2014-07-09 19:40:08 +0000
committerAlexey Samsonov <vonosmas@gmail.com>2014-07-09 19:40:08 +0000
commite21afe131a825f27d71230f4cca327945207a08c (patch)
treeafd54be30e6428b7df5bb47f8526353662ceb2f3 /lib/Driver/CMakeLists.txt
parent48f80aa9abf55d5a2e195e2e8a58fb6e12f3887c (diff)
Decouple llvm::SpecialCaseList text representation and its LLVM IR semantics.
Turn llvm::SpecialCaseList into a simple class that parses text files in a specified format and knows nothing about LLVM IR. Move this class into LLVMSupport library. Implement two users of this class: * DFSanABIList in DFSan instrumentation pass. * SanitizerBlacklist in Clang CodeGen library. The latter will be modified to use actual source-level information from frontend (source file names) instead of unstable LLVM IR things (LLVM Module identifier). Remove dependency edge from ClangCodeGen/ClangDriver to LLVMTransformUtils. No functionality change. git-svn-id: https://llvm.org/svn/llvm-project/cfe/trunk@212643 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/Driver/CMakeLists.txt')
-rw-r--r--lib/Driver/CMakeLists.txt1
1 files changed, 0 insertions, 1 deletions
diff --git a/lib/Driver/CMakeLists.txt b/lib/Driver/CMakeLists.txt
index e9e9d913f1..33db5e9a9e 100644
--- a/lib/Driver/CMakeLists.txt
+++ b/lib/Driver/CMakeLists.txt
@@ -1,7 +1,6 @@
set(LLVM_LINK_COMPONENTS
Option
Support
- TransformUtils
)
add_clang_library(clangDriver