summaryrefslogtreecommitdiffstats
path: root/lib/Index/CMakeLists.txt
diff options
context:
space:
mode:
authorNAKAMURA Takumi <geek4civic@gmail.com>2013-12-09 19:04:43 +0000
committerNAKAMURA Takumi <geek4civic@gmail.com>2013-12-09 19:04:43 +0000
commit921fa378cc3c9a15746ea509447c97e2a1f84390 (patch)
tree7b6fa9042cec3504ca6b1ea17a8aecd123a2ead9 /lib/Index/CMakeLists.txt
parent6b4f43651522697cf3f1ace40c41940d3cc3af5e (diff)
[CMake] clang/lib: Satisfy dependencies to add *actually used* libraries on target_link_libraries() and LLVM_LINK_COMPONENTS.
I will prune redundant dependencies later. git-svn-id: https://llvm.org/svn/llvm-project/cfe/trunk@196800 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/Index/CMakeLists.txt')
-rw-r--r--lib/Index/CMakeLists.txt9
1 files changed, 8 insertions, 1 deletions
diff --git a/lib/Index/CMakeLists.txt b/lib/Index/CMakeLists.txt
index c4ff5a0130..0a9b568360 100644
--- a/lib/Index/CMakeLists.txt
+++ b/lib/Index/CMakeLists.txt
@@ -1,3 +1,7 @@
+set(LLVM_LINK_COMPONENTS
+ Support
+ )
+
add_clang_library(clangIndex
CommentToXML.cpp
SimpleFormatContext.h
@@ -5,7 +9,10 @@ add_clang_library(clangIndex
)
target_link_libraries(clangIndex
- clangBasic
clangAST
+ clangBasic
clangFormat
+ clangLex
+ clangRewriteCore
+ clangTooling
)