summaryrefslogtreecommitdiffstats
path: root/lib/Index/CMakeLists.txt
diff options
context:
space:
mode:
authorArgyrios Kyrtzidis <akyrtzi@gmail.com>2009-07-05 22:22:19 +0000
committerArgyrios Kyrtzidis <akyrtzi@gmail.com>2009-07-05 22:22:19 +0000
commit9eec4ed6ca0dcf098580da9146b97e0841556d12 (patch)
tree990b7278fb0983249a24c985f00fc4ff361a7d42 /lib/Index/CMakeLists.txt
parent2c2ba3e258961dd98cacffe3a2167bb6d958fd53 (diff)
Introduce the 'Index' library.
Its purpose is to provide the basic infrastructure for cross-translation-unit analysis like indexing, refactoring, etc. Currently it is very "primitive" and with no type-names support. It can provide functionality like "show me all references of this function from these translation units". git-svn-id: https://llvm.org/svn/llvm-project/cfe/trunk@74802 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/Index/CMakeLists.txt')
-rw-r--r--lib/Index/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/lib/Index/CMakeLists.txt b/lib/Index/CMakeLists.txt
new file mode 100644
index 0000000000..90b6001027
--- /dev/null
+++ b/lib/Index/CMakeLists.txt
@@ -0,0 +1,7 @@
+set(LLVM_NO_RTTI 1)
+
+add_clang_library(clangIndex
+ Entity.cpp
+ IndexProvider.cpp
+ Program.cpp
+ )