summaryrefslogtreecommitdiffstats
path: root/lib/Index/CMakeLists.txt
diff options
context:
space:
mode:
authorDouglas Gregor <dgregor@apple.com>2010-09-08 21:40:53 +0000
committerDouglas Gregor <dgregor@apple.com>2010-09-08 21:40:53 +0000
commitbfae8bd6259460ae0668cad39c141504511d19b0 (patch)
treeb5a5c89157c5d9f4c20eaf0ca0d09a8a16b55c7b /lib/Index/CMakeLists.txt
parent19311e70edaa2d7bb0d709344aebea4fbbae2da4 (diff)
Clean up some of the CMake dependencies
git-svn-id: https://llvm.org/svn/llvm-project/cfe/trunk@113416 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/Index/CMakeLists.txt')
-rw-r--r--lib/Index/CMakeLists.txt14
1 files changed, 14 insertions, 0 deletions
diff --git a/lib/Index/CMakeLists.txt b/lib/Index/CMakeLists.txt
index 61f69b218e..ec39dffeba 100644
--- a/lib/Index/CMakeLists.txt
+++ b/lib/Index/CMakeLists.txt
@@ -1,5 +1,19 @@
set(LLVM_NO_RTTI 1)
+set( LLVM_USED_LIBS
+ clangSerialization
+ clangFrontend
+ clangParse
+ clangSema
+ clangChecker
+ clangAnalysis
+ clangIndex
+ clangRewrite
+ clangAST
+ clangLex
+ clangBasic
+ )
+
add_clang_library(clangIndex
ASTLocation.cpp
Analyzer.cpp