summaryrefslogtreecommitdiffstats
path: root/lib/Sema/CMakeLists.txt
diff options
context:
space:
mode:
authorJohn McCall <rjmccall@apple.com>2010-08-20 18:27:03 +0000
committerJohn McCall <rjmccall@apple.com>2010-08-20 18:27:03 +0000
commit19510856727e0e14a3696b2a72c35163bff2a71f (patch)
treeaa4cb42590b8bf0df7ffb7115c7d74c4a68ef3f2 /lib/Sema/CMakeLists.txt
parent033b7b327e8cdc8cd4bafce1625ea88bc9e3f6c8 (diff)
Another step in the process of making the parser depend on Sema:
- move DeclSpec &c into the Sema library - move ParseAST into the Parse library Reflect this change in a thousand different includes. Reflect this change in the link orders. git-svn-id: https://llvm.org/svn/llvm-project/cfe/trunk@111667 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/Sema/CMakeLists.txt')
-rw-r--r--lib/Sema/CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/lib/Sema/CMakeLists.txt b/lib/Sema/CMakeLists.txt
index 70b4792f3b..2144bfefb1 100644
--- a/lib/Sema/CMakeLists.txt
+++ b/lib/Sema/CMakeLists.txt
@@ -1,11 +1,13 @@
set(LLVM_NO_RTTI 1)
add_clang_library(clangSema
+ Action.cpp
AnalysisBasedWarnings.cpp
+ AttributeList.cpp
CodeCompleteConsumer.cpp
+ DeclSpec.cpp
IdentifierResolver.cpp
JumpDiagnostics.cpp
- ParseAST.cpp
Sema.cpp
SemaAccess.cpp
SemaAttr.cpp