summaryrefslogtreecommitdiffstats
path: root/lib/Sema/CMakeLists.txt
diff options
context:
space:
mode:
authorEli Bendersky <eliben@google.com>2014-09-03 15:27:03 +0000
committerEli Bendersky <eliben@google.com>2014-09-03 15:27:03 +0000
commit59c0e21c942b6a39622a6c948afbddb9c5064113 (patch)
tree9933bb979840009c6fb3321ec239076142577767 /lib/Sema/CMakeLists.txt
parentd91dc0875630e6d2c81363b2801ed47257daa026 (diff)
Split off CUDA-specific Sema parts to a new file
In line with SemaOpenMP.cpp, etc. CUDA-specific semantic analysis code goes into a separate file. This is in anticipation of adding extra functionality here in the near future. No change in functionality. Review: http://reviews.llvm.org/D5160 git-svn-id: https://llvm.org/svn/llvm-project/cfe/trunk@217043 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/Sema/CMakeLists.txt')
-rw-r--r--lib/Sema/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/lib/Sema/CMakeLists.txt b/lib/Sema/CMakeLists.txt
index 7847d2c36e..4a772d8972 100644
--- a/lib/Sema/CMakeLists.txt
+++ b/lib/Sema/CMakeLists.txt
@@ -21,6 +21,7 @@ add_clang_library(clangSema
SemaChecking.cpp
SemaCodeComplete.cpp
SemaConsumer.cpp
+ SemaCUDA.cpp
SemaDecl.cpp
SemaDeclAttr.cpp
SemaDeclCXX.cpp