summaryrefslogtreecommitdiffstats
path: root/lib/Sema/CMakeLists.txt
diff options
context:
space:
mode:
authorBenjamin Kramer <benny.kra@googlemail.com>2012-08-09 22:33:50 +0000
committerBenjamin Kramer <benny.kra@googlemail.com>2012-08-09 22:33:50 +0000
commit7bac4b2f3e5b89644af410b28496dd4fbfc740a7 (patch)
treebc65df439ed12dcd60572f24f104fdb330980c94 /lib/Sema/CMakeLists.txt
parent613f44418b55c39c1d3f30c5e8f52f3e3248384c (diff)
CMake: Add the new dependency from libSema to LLVM's libs.
Should fix the failures seen on some linux builders. git-svn-id: https://llvm.org/svn/llvm-project/cfe/trunk@161629 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/Sema/CMakeLists.txt')
-rw-r--r--lib/Sema/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/lib/Sema/CMakeLists.txt b/lib/Sema/CMakeLists.txt
index 9780f515c9..46dfa05ade 100644
--- a/lib/Sema/CMakeLists.txt
+++ b/lib/Sema/CMakeLists.txt
@@ -1,3 +1,10 @@
+set(LLVM_LINK_COMPONENTS
+ ${LLVM_TARGETS_TO_BUILD}
+ asmparser
+ support
+ mc
+ )
+
add_clang_library(clangSema
AnalysisBasedWarnings.cpp
AttributeList.cpp