summaryrefslogtreecommitdiffstats
path: root/lib/Sema/CMakeLists.txt
diff options
context:
space:
mode:
authorAaron Ballman <aaron@aaronballman.com>2013-09-09 23:33:17 +0000
committerAaron Ballman <aaron@aaronballman.com>2013-09-09 23:33:17 +0000
commitbbb3b3237df2284f6f3c34798944fcfa4b43fd34 (patch)
tree6a2893bd0d033dc570fa80dfd3138d60312ee49a /lib/Sema/CMakeLists.txt
parenta7be2f4c745120d6ee5adfd19ef259919bdc3f7f (diff)
Attribute tablegen now understands that attribute arguments can be optional. This allows for automated checking of the number of arguments expected vs number of arguments given for attributes. Greatly reduces the amount of manual checking required.
git-svn-id: https://llvm.org/svn/llvm-project/cfe/trunk@190368 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/Sema/CMakeLists.txt')
-rw-r--r--lib/Sema/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/lib/Sema/CMakeLists.txt b/lib/Sema/CMakeLists.txt
index 836d125978..5e0914086c 100644
--- a/lib/Sema/CMakeLists.txt
+++ b/lib/Sema/CMakeLists.txt
@@ -60,6 +60,7 @@ add_dependencies(clangSema
ClangAttrList
ClangAttrParsedAttrList
ClangAttrParsedAttrKinds
+ ClangAttrParsedAttrImpl
ClangAttrSpellingListIndex
ClangAttrTemplateInstantiate
ClangCommentNodes