summaryrefslogtreecommitdiffstats
path: root/lib/Sema/CMakeLists.txt
diff options
context:
space:
mode:
authorJordan Rose <jordan_rose@apple.com>2012-09-28 22:21:39 +0000
committerJordan Rose <jordan_rose@apple.com>2012-09-28 22:21:39 +0000
commita55d32d1b8f799bf58c02540983976368c42d895 (patch)
tree44d03bcc9c186ee09eb25d5d1965205696d39e7f /lib/Sema/CMakeLists.txt
parent7a2704800943fbb69207e125d28186278712af36 (diff)
Pull ScopeInfo implementation into its own file.
The infrastructure for -Warc-repeated-use-of-weak got a little too heavy to leave sitting at the top of Sema.cpp. No functionality change. git-svn-id: https://llvm.org/svn/llvm-project/cfe/trunk@164856 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/Sema/CMakeLists.txt')
-rw-r--r--lib/Sema/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/lib/Sema/CMakeLists.txt b/lib/Sema/CMakeLists.txt
index 872ac89672..f554b5ca9b 100644
--- a/lib/Sema/CMakeLists.txt
+++ b/lib/Sema/CMakeLists.txt
@@ -14,6 +14,7 @@ add_clang_library(clangSema
IdentifierResolver.cpp
JumpDiagnostics.cpp
Scope.cpp
+ ScopeInfo.cpp
Sema.cpp
SemaAccess.cpp
SemaAttr.cpp