summaryrefslogtreecommitdiffstats
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorAlp Toker <alp@nuanti.com>2014-07-14 22:17:16 +0000
committerAlp Toker <alp@nuanti.com>2014-07-14 22:17:16 +0000
commit8a534e04e6666a589eff8651d954ae3ff9144b06 (patch)
tree30b76e14440500edd37c886ad6a269c57988432a /test/CMakeLists.txt
parent738e858bfcdfa962217264f3f07105d5f16ec3b2 (diff)
Fix the !CLANG_ENABLE_ARCMT build
git-svn-id: https://llvm.org/svn/llvm-project/cfe/trunk@212995 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt9
1 files changed, 8 insertions, 1 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index fe80df4564..2052873cb3 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -26,11 +26,18 @@ endif ()
list(APPEND CLANG_TEST_DEPS
clang clang-headers
- c-index-test diagtool arcmt-test c-arcmt-test
+ c-index-test diagtool
clang-check clang-format
clang-tblgen
)
+if (CLANG_ENABLE_ARCMT)
+ list(APPEND CLANG_TEST_DEPS
+ arcmt-test
+ c-arcmt-test
+ )
+endif ()
+
if (ENABLE_CLANG_EXAMPLES)
list(APPEND CLANG_TEST_DEPS
clang-interpreter