summaryrefslogtreecommitdiffstats
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorNAKAMURA Takumi <geek4civic@gmail.com>2010-11-29 01:18:56 +0000
committerNAKAMURA Takumi <geek4civic@gmail.com>2010-11-29 01:18:56 +0000
commit3aa8c64305198037b5ef2a7335ea5f033811f21a (patch)
treec87af0e02eebb5bd47f2dcb5882ac74ccc9eb21e /test/CMakeLists.txt
parentfc86d55b6b20c47f67a61afa4b3903eb0d31f9b8 (diff)
test/CMakeLists.txt: Implement the target "check-all". For now, it has no dependencies.
git-svn-id: https://llvm.org/svn/llvm-project/cfe/trunk@120280 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index 4d02d2b3eb..42c63fccf4 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -77,4 +77,14 @@ if(PYTHONINTERP_FOUND)
${CMAKE_CURRENT_SOURCE_DIR}/../utils/C++Tests
DEPENDS clang c-index-test FileCheck not count
COMMENT "Running Clang regression tests")
+
+ add_custom_target(check-all
+ COMMAND ${PYTHON_EXECUTABLE}
+ ${LLVM_SOURCE_DIR}/utils/lit/lit.py
+ --param build_config=${CMAKE_CFG_INTDIR}
+ --param build_mode=${RUNTIME_BUILD_MODE}
+ ${LIT_ARGS}
+ ${LLVM_BINARY_DIR}/test
+ ${CMAKE_CURRENT_BINARY_DIR}
+ COMMENT "Running Clang and LLVM regression tests")
endif()