summaryrefslogtreecommitdiffstats
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorOscar Fuentes <ofv@wanadoo.es>2011-02-20 22:06:44 +0000
committerOscar Fuentes <ofv@wanadoo.es>2011-02-20 22:06:44 +0000
commita3f787c32b84a5c66d48e1b9713bdd66d3866f57 (patch)
tree377d2bd265759c2d1b703b20b18adfe9bed5334a /test/CMakeLists.txt
parentc8da1ecaf58ff41b652dd53331aace948027039b (diff)
Put targets on folders, if the IDE supports the feature.
Requires CMake 2.8.3 or newer. git-svn-id: https://llvm.org/svn/llvm-project/cfe/trunk@126094 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index a32b9943c2..0a05447f9d 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -69,6 +69,7 @@ if(PYTHONINTERP_FOUND)
separate_arguments(LIT_ARGS)
add_custom_target(clang-test.deps)
+ set_target_properties(clang-test.deps PROPERTIES FOLDER "Clang tests")
foreach(testdir ${CLANG_TEST_DIRECTORIES})
add_custom_target(clang-test-${testdir}
@@ -80,6 +81,7 @@ if(PYTHONINTERP_FOUND)
${CMAKE_CURRENT_BINARY_DIR}/${testdir}
DEPENDS clang c-index-test FileCheck not count
COMMENT "Running Clang regression tests in ${testdir}")
+ set_target_properties(clang-test-${testdir} PROPERTIES FOLDER "Clang tests")
endforeach()
add_custom_target(clang-test
@@ -92,6 +94,7 @@ if(PYTHONINTERP_FOUND)
${LIT_ARGS}
${CMAKE_CURRENT_BINARY_DIR}
COMMENT "Running Clang regression tests")
+ set_target_properties(clang-test PROPERTIES FOLDER "Clang tests")
add_custom_target(clang-c++tests
COMMAND ${PYTHON_EXECUTABLE}
@@ -102,6 +105,7 @@ if(PYTHONINTERP_FOUND)
${CMAKE_CURRENT_SOURCE_DIR}/../utils/C++Tests
DEPENDS clang c-index-test FileCheck not count
COMMENT "Running Clang regression tests")
+ set_target_properties(clang-c++tests PROPERTIES FOLDER "Clang tests")
if( NOT CLANG_BUILT_STANDALONE )
add_custom_target(check-all
@@ -119,7 +123,7 @@ if(PYTHONINTERP_FOUND)
llvm-dis opt
FileCheck count not
)
-
+ set_target_properties(check-all PROPERTIES FOLDER "Clang tests")
endif()
add_dependencies(clang-test clang-test.deps)