summaryrefslogtreecommitdiffstats
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorYaron Keren <yaron.keren@gmail.com>2016-06-01 13:47:26 +0000
committerYaron Keren <yaron.keren@gmail.com>2016-06-01 13:47:26 +0000
commit13ad43d114bc8e985bda79d179f8152db84b006c (patch)
tree62e7d01ce9c0fd3651848dbcb533982d7876112e /test/CMakeLists.txt
parent17ed5983fe6880b1c3530e2431001674d6e1b911 (diff)
Fix the CLANG_ENABLE_STATIC_ANALYZER=OFF build.
tools/clang/tools/CMakeLists.txt does not create the clang-check target when CLANG_ENABLE_STATIC_ANALYZER=OFF. git-svn-id: https://llvm.org/svn/llvm-project/cfe/trunk@271392 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt8
1 files changed, 7 insertions, 1 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index c6cad7997d..ca8c984f7d 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -26,10 +26,16 @@ endif ()
list(APPEND CLANG_TEST_DEPS
clang clang-headers
- clang-check clang-format
+ clang-format
c-index-test diagtool
clang-tblgen
)
+
+if(CLANG_ENABLE_STATIC_ANALYZER)
+ list(APPEND CLANG_TEST_DEPS
+ clang-check
+ )
+endif()
if (CLANG_ENABLE_ARCMT)
list(APPEND CLANG_TEST_DEPS