summaryrefslogtreecommitdiffstats
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorChris Bieneman <beanz@apple.com>2016-03-02 00:27:15 +0000
committerChris Bieneman <beanz@apple.com>2016-03-02 00:27:15 +0000
commit73383157c534bbad9c2089919cc8a8ef0ebc0aa7 (patch)
tree927c229ec8cf5112f02e944b015ce75ef7495b09 /test/CMakeLists.txt
parent22446c6ca7d775642eb2e8fffbc622b0a18d388c (diff)
[CMake] Add convenience target clang-test-depends to build test dependencies.
This is useful when paired with the distribution targets to build prerequisites for running tests. git-svn-id: https://llvm.org/svn/llvm-project/cfe/trunk@262429 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index 8dd64d1614..f1a5838f6b 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -71,6 +71,8 @@ if( NOT CLANG_BUILT_STANDALONE )
)
endif()
+add_custom_target(clang-test-depends DEPENDS ${CLANG_TEST_DEPS})
+
add_lit_testsuite(check-clang "Running the Clang regression tests"
${CMAKE_CURRENT_BINARY_DIR}
#LIT ${LLVM_LIT}