summaryrefslogtreecommitdiffstats
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorJustin Bogner <mail@justinbogner.com>2014-04-17 22:49:06 +0000
committerJustin Bogner <mail@justinbogner.com>2014-04-17 22:49:06 +0000
commitdea85f9d241126f844cc46d4e91e7755c8e1851c (patch)
treef1c9032f718b0708d5a0fc79d95ade300141d895 /test/CMakeLists.txt
parentc911bf1a4ad6146dfb8c91410db219c582172c44 (diff)
test: Use llvm-profdata merge in Profile tests
In preparation for using a binary format for instrumentation based profiling, explicitly treat the test inputs as text and transform them before running. This will allow us to leave the checked in files in human readable format once the instrumentation format is binary. No functional change. git-svn-id: https://llvm.org/svn/llvm-project/cfe/trunk@206509 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index 209154003a..970c7b96b3 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -39,7 +39,7 @@ set(CLANG_TEST_PARAMS
if( NOT CLANG_BUILT_STANDALONE )
list(APPEND CLANG_TEST_DEPS
llvm-config
- llc opt FileCheck count not llvm-symbolizer
+ llc opt FileCheck count not llvm-symbolizer llvm-profdata
)
endif()