summaryrefslogtreecommitdiffstats
path: root/tools/CMakeLists.txt
diff options
context:
space:
mode:
authorEugene Zelenko <eugene.zelenko@gmail.com>2016-01-13 02:03:50 +0000
committerEugene Zelenko <eugene.zelenko@gmail.com>2016-01-13 02:03:50 +0000
commit1f54fb1b5a76d0fa9d956baa523845b4861c0915 (patch)
tree40becca978feae86ba0dfc14efcbd666e6bd2c8d /tools/CMakeLists.txt
parent2824a0744ca037a1b976efcc1d848aecb41dabd5 (diff)
Install scan-build and scan-view only if Static Analyzer was enabled.
git-svn-id: https://llvm.org/svn/llvm-project/cfe/trunk@257562 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'tools/CMakeLists.txt')
-rw-r--r--tools/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/tools/CMakeLists.txt b/tools/CMakeLists.txt
index dba676a1f7..510bc44f40 100644
--- a/tools/CMakeLists.txt
+++ b/tools/CMakeLists.txt
@@ -5,8 +5,6 @@ add_clang_subdirectory(driver)
add_clang_subdirectory(clang-format)
add_clang_subdirectory(clang-format-vs)
add_clang_subdirectory(clang-fuzzer)
-add_clang_subdirectory(scan-build)
-add_clang_subdirectory(scan-view)
add_clang_subdirectory(c-index-test)
add_clang_subdirectory(libclang)
@@ -18,6 +16,8 @@ endif()
if(CLANG_ENABLE_STATIC_ANALYZER)
add_clang_subdirectory(clang-check)
+ add_clang_subdirectory(scan-build)
+ add_clang_subdirectory(scan-view)
endif()
# We support checking out the clang-tools-extra repository into the 'extra'