summaryrefslogtreecommitdiffstats
path: root/examples/analyzer-plugin/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/analyzer-plugin/CMakeLists.txt')
-rw-r--r--examples/analyzer-plugin/CMakeLists.txt14
1 files changed, 14 insertions, 0 deletions
diff --git a/examples/analyzer-plugin/CMakeLists.txt b/examples/analyzer-plugin/CMakeLists.txt
new file mode 100644
index 0000000000..865422684c
--- /dev/null
+++ b/examples/analyzer-plugin/CMakeLists.txt
@@ -0,0 +1,14 @@
+set(MODULE TRUE)
+
+set( LLVM_USED_LIBS
+ clangStaticAnalyzerCore
+ )
+
+set( LLVM_LINK_COMPONENTS support mc)
+
+add_clang_library(SampleAnalyzerPlugin SampleAnalyzerPlugin)
+
+set_target_properties(SampleAnalyzerPlugin
+ PROPERTIES
+ LINKER_LANGUAGE CXX
+ PREFIX "")