summaryrefslogtreecommitdiffstats
path: root/lib/Index/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'lib/Index/CMakeLists.txt')
-rw-r--r--lib/Index/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/lib/Index/CMakeLists.txt b/lib/Index/CMakeLists.txt
index c9fbfafcf9..38d84e4c19 100644
--- a/lib/Index/CMakeLists.txt
+++ b/lib/Index/CMakeLists.txt
@@ -6,12 +6,14 @@ set(LLVM_LINK_COMPONENTS
add_clang_library(clangIndex
CodegenNameGenerator.cpp
CommentToXML.cpp
+ FileIndexData.cpp
IndexBody.cpp
IndexDecl.cpp
IndexingAction.cpp
IndexingContext.cpp
IndexSymbol.cpp
IndexTypeSourceInfo.cpp
+ UnitIndexDataRecorder.cpp
USRGeneration.cpp
ADDITIONAL_HEADERS
@@ -23,6 +25,7 @@ add_clang_library(clangIndex
clangBasic
clangFormat
clangFrontend
+ clangLex
clangRewrite
clangSerialization
clangToolingCore