summaryrefslogtreecommitdiffstats
path: root/tools/clang-extdef-mapping/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tools/clang-extdef-mapping/CMakeLists.txt')
-rw-r--r--tools/clang-extdef-mapping/CMakeLists.txt21
1 files changed, 21 insertions, 0 deletions
diff --git a/tools/clang-extdef-mapping/CMakeLists.txt b/tools/clang-extdef-mapping/CMakeLists.txt
new file mode 100644
index 0000000000..6c81689a83
--- /dev/null
+++ b/tools/clang-extdef-mapping/CMakeLists.txt
@@ -0,0 +1,21 @@
+set(LLVM_LINK_COMPONENTS
+ ${LLVM_TARGETS_TO_BUILD}
+ support
+ )
+
+add_clang_executable(clang-extdef-mapping
+ ClangExtDefMapGen.cpp
+ )
+
+target_link_libraries(clang-extdef-mapping
+ PRIVATE
+ clangAST
+ clangBasic
+ clangCrossTU
+ clangFrontend
+ clangSerialization
+ clangTooling
+ )
+
+install(TARGETS clang-extdef-mapping
+ RUNTIME DESTINATION bin)