summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPetr Hosek <phosek@chromium.org>2017-03-23 22:40:10 +0000
committerPetr Hosek <phosek@chromium.org>2017-03-23 22:40:10 +0000
commit3d91fe7c1a965599bb4c0f974b07a10d619b4d3d (patch)
treed38ebbe60c4e4464d2e797d01f37b0ed3a03185b /CMakeLists.txt
parent2884223490c6e0142cbb2ef2f19b196850fd2ab4 (diff)
[CMake] Provide an option to disable runtimes build
This could be used to either disable the runtimes build altogether or avoid building them but still generate the build targets. Differential Revision: https://reviews.llvm.org/D31060 git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@298653 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 7 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 47bd35c09887..b51bc421fdbf 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -483,6 +483,10 @@ option(LLVM_INCLUDE_UTILS "Generate build targets for the LLVM utils." ON)
option(LLVM_BUILD_UTILS
"Build LLVM utility binaries. If OFF, just generate build targets." ON)
+option(LLVM_INCLUDE_RUNTIMES "Generate build targets for the LLVM runtimes." ON)
+option(LLVM_BUILD_RUNTIMES
+ "Build the LLVM runtimes. If OFF, just generate build targets." ON)
+
option(LLVM_BUILD_RUNTIME
"Build the LLVM runtime libraries." ON)
option(LLVM_BUILD_EXAMPLES
@@ -862,7 +866,9 @@ if( LLVM_INCLUDE_TOOLS )
add_subdirectory(tools)
endif()
-add_subdirectory(runtimes)
+if( LLVM_INCLUDE_RUNTIMES )
+ add_subdirectory(runtimes)
+endif()
if( LLVM_INCLUDE_EXAMPLES )
add_subdirectory(examples)