summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDan Liew <dan@su-root.co.uk>2016-01-08 22:36:22 +0000
committerDan Liew <dan@su-root.co.uk>2016-01-08 22:36:22 +0000
commitad637ba2fd19f34a68d2c4e7f6fff4c79db91f5c (patch)
tree527db6c73f71515116cdc06cab56b5f15fe3b986 /CMakeLists.txt
parent4704a2c28432abe0efaeee88f1b61e36a796163e (diff)
Teach the CMake build system to run lit's test suite. These can be run
directy with ``make check-lit`` and are run as part of ``make check-all``. In principle we should run lit's testsuite before testing LLVM using lit so that any problems with lit get discovered before testing LLVM so we can bail out early. However this implementation (``check-all`` runs all tests together) seemed simpler and will still report failing lit tests. Note that the tests and the configured ``lit.site.cfg`` have to be copied into the build directory to avoid polluting the source tree. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@257221 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3d2093fde634..bfd454323dce 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -697,6 +697,7 @@ if( LLVM_INCLUDE_TESTS )
EXCLUDE_FROM_ALL
NO_INSTALL)
endif()
+ add_subdirectory(utils/lit)
add_subdirectory(test)
add_subdirectory(unittests)
if (MSVC)