summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMehdi Amini <mehdi.amini@apple.com>2016-11-07 17:43:08 +0000
committerMehdi Amini <mehdi.amini@apple.com>2016-11-07 17:43:08 +0000
commitad83acaba55c90df4d17877849dc5694c431b68f (patch)
tree1342ba9503384ee49a3ef0441bec13b4746f768d /CMakeLists.txt
parent644ae71ae07b9741ac9908912b7b2784b0ab616a (diff)
Revert "Add some facilities to work with a git monorepo (experimental setup)"
This reverts commit r286123, accidentally commited while testing itself... git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@286124 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt19
1 files changed, 0 insertions, 19 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ab43a4a603d5..7a70ebcf4b4d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -93,25 +93,6 @@ if(CMAKE_HOST_APPLE AND APPLE)
endif()
endif()
-# Git Mono-Repo handling: automatically set the LLVM_EXTERNAL_${project}_SOURCE_DIR
-set(LLVM_ALL_PROJECTS "clang;libcxx;libcxxabi;lldb;compiler-rt;lld;polly")
-set(LLVM_ENABLE_PROJECTS "" CACHE STRING
- "Semicolon-separated list of projects to build (${LLVM_ALL_PROJECTS}), or \"all\".")
-if( LLVM_ENABLE_PROJECTS STREQUAL "all" )
- set( LLVM_ENABLE_PROJECTS ${LLVM_ALL_PROJECTS})
-endif()
-foreach(proj ${LLVM_ENABLE_PROJECTS})
- set(PROJ_DIR "${CMAKE_CURRENT_SOURCE_DIR}/../${proj}")
- if(NOT EXISTS "${PROJ_DIR}" OR NOT IS_DIRECTORY "${PROJ_DIR}")
- message(FATAL_ERROR "LLVM_ENABLE_PROJECTS requests ${proj} but directory not found: ${PROJ_DIR}")
- endif()
- string(TOUPPER "${proj}" upper_proj)
- set(LLVM_EXTERNAL_${upper_proj}_SOURCE_DIR "${CMAKE_CURRENT_SOURCE_DIR}/../${proj}")
- if (proj STREQUAL "clang")
- set(LLVM_EXTERNAL_CLANG_TOOLS_EXTRA_SOURCE_DIR "${CMAKE_CURRENT_SOURCE_DIR}/../clang-tools-extra")
- endif()
-endforeach()
-
# The following only works with the Ninja generator in CMake >= 3.0.
set(LLVM_PARALLEL_COMPILE_JOBS "" CACHE STRING
"Define the maximum number of concurrent compilation jobs.")