summaryrefslogtreecommitdiffstats
path: root/lldb/source/Plugins/SymbolLocator/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'lldb/source/Plugins/SymbolLocator/CMakeLists.txt')
-rw-r--r--lldb/source/Plugins/SymbolLocator/CMakeLists.txt7
1 files changed, 6 insertions, 1 deletions
diff --git a/lldb/source/Plugins/SymbolLocator/CMakeLists.txt b/lldb/source/Plugins/SymbolLocator/CMakeLists.txt
index ca969626f4ff..3367022639ab 100644
--- a/lldb/source/Plugins/SymbolLocator/CMakeLists.txt
+++ b/lldb/source/Plugins/SymbolLocator/CMakeLists.txt
@@ -1,5 +1,10 @@
+# Order matters here: the first symbol locator prevents further searching.
+# For DWARF binaries that are both stripped and split, the Default plugin
+# will return the stripped binary when asked for the ObjectFile, which then
+# prevents an unstripped binary from being requested from the Debuginfod
+# provider.
+add_subdirectory(Debuginfod)
add_subdirectory(Default)
if (CMAKE_SYSTEM_NAME MATCHES "Darwin")
add_subdirectory(DebugSymbols)
endif()
-add_subdirectory(Debuginfod)