summaryrefslogtreecommitdiffstats
path: root/installerbuilder/libinstaller/qinstallercomponent.cpp
Commit message (Collapse)AuthorAgeFilesLines
* Rename to match actual class name. Fix includes.kh12011-06-091-1076/+0
|
* Add convenient function.kh12011-06-071-0/+5
|
* Use the now stored component name.kh12011-06-061-1/+1
|
* Handle virtual components differently.kh12011-06-061-1/+1
| | | | | | | | | | Review-by: tjenssen Checking/ unchecking a virtual component does not modify the parent item. Checking/ unchecking a parent item that owns virtual components does not modify the components check state. Dependencies to virtual components should get resolved later, so we do not need to handle them at all.
* Add convenient function.kh12011-06-061-1/+6
|
* m_name is now m_componentName on the component private classTim Jenssen2011-06-061-2/+4
|
* now we have a default tag which can contain true or scriptTim Jenssen2011-06-011-9/+25
|
* removed unused autoselecton valueTim Jenssen2011-06-011-2/+0
| | | | Review-by: kh1
* Fixes a memory leak in QUiLoader.kh12011-05-041-1/+1
| | | | | We would leak on every invokation an Translation Watcher object, as there is no parent widget to delete it.
* Whitespaces. Fix some spelling errors.kh12011-04-211-13/+13
|
* Make sure we take only "real" components into account.kh12011-04-201-3/+3
| | | | Fixes the wrongly enabled "Next" on component selection.
* Merge branch 'refactor' of ↵kh12011-04-141-58/+56
|\ | | | | | | | | | | | | scm.dev.nokia.troll.no:installer-framework/mainline into refactor Conflicts: installerbuilder/libinstaller/qinstaller.cpp
| * Remove default arguments.kh12011-04-131-3/+3
| |
| * Cleanup, no functional change.kh12011-04-131-55/+53
| | | | | | | | | | Removed some superfluous variables. Rename some variable names to match style guide.
* | Some more constants.kh12011-04-121-8/+10
|/
* Add some convenient functions.kh12011-04-121-12/+24
| | | | | Should make it easier to set the components installed state, no need to fiddle with the variable names.
* Resolve todo.kh12011-04-121-7/+0
|
* Fix the selected state handling.kh12011-04-121-112/+14
|
* Make sure we properly set the check state.kh12011-04-121-8/+11
|
* No default arguments anymore. RunModes -> RunModekh12011-04-121-5/+5
|
* Merge branch 'master' into refactorkh12011-04-121-1/+1
|\ | | | | | | | | Conflicts: installerbuilder/libinstaller/qinstallercomponent.cpp
| * fix the fixTim Jenssen2011-04-121-1/+1
| |
| * fix that unvisible components keep selected if there is no selected visible ↵Tim Jenssen2011-04-111-2/+28
| | | | | | | | | | | | component - should fix: QTSDK-654, QTSDK-642, QTSDK-329
* | Remove/ Comment out, going to rework dep handling anyway.kh12011-04-051-90/+88
| |
* | Add slot to setup model data.kh12011-04-011-0/+34
| |
* | Add a method to return the uncompressed size as string.kh12011-04-011-0/+15
| |
* | Add a remove component function. Does not delete.kh12011-04-011-0/+14
| |
* | Keep components in seperate list.kh12011-04-011-7/+16
| | | | | | | | | | | | Have a list for normal and virtual components. Also sort the normal components when they get added. Still childComponents() will return the full components list.
* | Add a helper class to hide the model handling.kh12011-03-231-105/+20
| |
* | Use the private class. Move the RunModes enum.kh12011-03-231-149/+10
| | | | | | | | | | The enum should have been there before, so move it to the qinstallerglobal.h file.
* | Some more getter for model handling.kh12011-03-231-0/+19
| |
* | Add some model item methods.kh12011-03-231-4/+62
| |
* | Use the already existing ctor to load data.kh12011-03-211-10/+2
| |
* | Use statics. Make function private. Build fix.kh12011-03-171-88/+75
| | | | | | | | | | | | Make the local tmp path thing private, as it's rather useless to be able to set it from the outside. Should be done on component load. Adjust code to take that into account and compile.
* | Always pass the mode so we get the right components.kh12011-03-161-2/+2
| |
* | Merge branch 'master' into refactorkh12011-03-161-4/+9
|\| | | | | | | | | | | Conflicts: installerbuilder/installerbase/tabcontroller.cpp installerbuilder/libinstaller/qinstaller.cpp
| * added possibility to start an installer without force installations - for ↵Tim Jenssen2011-03-151-3/+8
| | | | | | | | better testing
* | Merge commit 'abbee7b0ec2e1fbc676b31949320b35a4c6620c7' into refactorkh12011-03-161-0/+21
|\| | | | | | | | | Conflicts: installerbuilder/libinstaller/qinstallercomponent.h
| * load the component scripts with help of new variable localTempPathTim Jenssen2011-03-151-0/+21
| |
* | Merge branch 'master' into refactorkh12011-03-141-5/+6
|\| | | | | | | | | | | Conflicts: installerbuilder/libinstaller/qinstallercomponent.cpp installerbuilder/libinstaller/qinstallercomponent.h
| * added some more values to load data methodTim Jenssen2011-03-141-5/+6
| |
* | Better naming.kh12011-03-131-3/+3
| | | | | | | | Actually we are asking for child components here.
* | Use foreach for better readability.kh12011-03-111-5/+3
| |
* | Fix indent.kh12011-03-111-19/+18
| |
* | Merge branch 'master' into refactorkh12011-03-111-0/+107
|\| | | | | | | | | | | Conflicts: installerbuilder/libinstaller/qinstallercomponent.cpp installerbuilder/libinstaller/qinstallercomponent.h
| * used new load data functions from component classTim Jenssen2011-03-101-16/+0
| |
| * added load data functionality inside component classTim Jenssen2011-03-101-0/+109
| |
* | Unify status values.kh12011-03-101-5/+9
| |
* | Cleanup. Style changes.kh12011-03-091-550/+550
|/
* init commitTim Jenssen2011-02-211-0/+1103