summaryrefslogtreecommitdiffstats
path: root/tests/modules/Application/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/modules/Application/CMakeLists.txt')
-rw-r--r--tests/modules/Application/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/tests/modules/Application/CMakeLists.txt b/tests/modules/Application/CMakeLists.txt
index efef3c3..7787d26 100644
--- a/tests/modules/Application/CMakeLists.txt
+++ b/tests/modules/Application/CMakeLists.txt
@@ -1,9 +1,11 @@
set(
APPLICATION_TEST_SOURCES
application_test.cpp
+ ${CMAKE_SOURCE_DIR}/tests/modules/common/qtmir_test.cpp
)
include_directories(
+ ${APPLICATION_API_INCLUDE_DIRS}
${CMAKE_SOURCE_DIR}/src/platforms/mirserver
${CMAKE_SOURCE_DIR}/src/modules
${CMAKE_SOURCE_DIR}/tests/modules/common
@@ -18,6 +20,8 @@ target_link_libraries(
unityapplicationplugin
qpa-mirserver
+ Qt5::Test
+
${GTEST_BOTH_LIBRARIES}
${GMOCK_LIBRARIES}
)