summaryrefslogtreecommitdiffstats
path: root/tests/modules/ApplicationManager/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/modules/ApplicationManager/CMakeLists.txt')
-rw-r--r--tests/modules/ApplicationManager/CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/tests/modules/ApplicationManager/CMakeLists.txt b/tests/modules/ApplicationManager/CMakeLists.txt
index 6590576..d90491c 100644
--- a/tests/modules/ApplicationManager/CMakeLists.txt
+++ b/tests/modules/ApplicationManager/CMakeLists.txt
@@ -2,9 +2,12 @@ set(
APPLICATION_MANAGER_TEST_SOURCES
application_manager_test.cpp
${CMAKE_SOURCE_DIR}/src/common/debughelpers.cpp
+ ${CMAKE_SOURCE_DIR}/tests/modules/common/qtmir_test.cpp
+ ../common/fake_mirsurfaceitem.h
)
include_directories(
+ ${APPLICATION_API_INCLUDE_DIRS}
${CMAKE_SOURCE_DIR}/src/platforms/mirserver
${CMAKE_SOURCE_DIR}/src/modules
${CMAKE_SOURCE_DIR}/tests/modules/common
@@ -15,7 +18,7 @@ add_executable(applicationmanager_test ${APPLICATION_MANAGER_TEST_SOURCES})
target_link_libraries(
applicationmanager_test
-
+
qpa-mirserver
unityapplicationplugin