summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorCristian Maureira-Fredes <cristian.maureira-fredes@qt.io>2019-02-12 10:21:22 +0100
committerCristian Maureira-Fredes <cristian.maureira-fredes@qt.io>2019-02-13 08:06:33 +0000
commit2137f859ec204c8adbb024f348e20a5b87c1792c (patch)
treedfdd7e8182133d517d0b29bb8bdf82fc9425507b
parent07997a77c6a6a61c23bb4b1a8a16d07c7aae39fb (diff)
Add dependency version for shiboken2
Since we specify: install_requires = ["shiboken2"] without a version, when trying to install: pip install PySide2==5.12.0 will install the latest shiboken version (5.12.1), and then of course there will be many issues related to the mismatch. This patch add the package_version to the shiboken2 dependency. Fixes: PYSIDE-929 Change-Id: I459cb22fc1506acfc861d33044bc3f7d2a85d85a Reviewed-by: Simo Fält <simo.falt@qt.io>
-rw-r--r--build_scripts/config.py4
1 files changed, 2 insertions, 2 deletions
diff --git a/build_scripts/config.py b/build_scripts/config.py
index 0b154766..cad4e2f5 100644
--- a/build_scripts/config.py
+++ b/build_scripts/config.py
@@ -198,7 +198,7 @@ class Config(object):
elif self.internal_build_type == self.shiboken_generator_option_name:
setup_kwargs['name'] = self.shiboken_generator_st_name
setup_kwargs['description'] = "Python / C++ bindings generator"
- setup_kwargs['install_requires'] = [self.shiboken_module_st_name]
+ setup_kwargs['install_requires'] = ["{}=={}".format(self.shiboken_module_st_name, package_version)]
setup_kwargs['entry_points'] = {
'console_scripts': [
'shiboken2 = {}.scripts.shiboken_tool:main'.format(self.package_name()),
@@ -208,7 +208,7 @@ class Config(object):
elif self.internal_build_type == self.pyside_option_name:
setup_kwargs['name'] = self.pyside_st_name
setup_kwargs['description'] = "Python bindings for the Qt cross-platform application and UI framework"
- setup_kwargs['install_requires'] = [self.shiboken_module_st_name]
+ setup_kwargs['install_requires'] = ["{}=={}".format(self.shiboken_module_st_name, package_version)]
setup_kwargs['entry_points'] = {
'console_scripts': [
'pyside2-uic = {}.scripts.uic:main'.format(self.package_name()),