summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorHugo Parente Lima <hugo.pl@gmail.com>2010-09-10 10:17:53 -0300
committerHugo Parente Lima <hugo.pl@gmail.com>2010-09-10 10:30:07 -0300
commit95e6f790de7b67df1c68f6c492c9b4e338492d25 (patch)
treeb40819abf99f5370ca9f2eab3e275131be2e7d83
parentbe5bd91e7234409c88a7a5b57dbfea699ea77add (diff)
Add PYSIDE_QT_VERSION to CMakeCache.txt.
This variable stores the Qt version used to compile PySide, so installers and packages can guess the min Qt version required to run PySide. Reviewer: Renato Ara├║jo <renato.filho@openbossa.org> Luciano Wolf <luciano.wolf@openbossa.org>
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index bd2146ad..1b99350e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -65,6 +65,7 @@ set(BINDING_API_MAJOR_VERSION "0")
set(BINDING_API_MINOR_VERSION "4")
set(BINDING_API_MICRO_VERSION "1")
set(BINDING_API_VERSION "${BINDING_API_MAJOR_VERSION}.${BINDING_API_MINOR_VERSION}.${BINDING_API_MICRO_VERSION}" CACHE STRING "PySide version" FORCE)
+set(PYSIDE_QT_VERSION "${QT_VERSION_MAJOR}.${QT_VERSION_MINOR}" CACHE STRING "Qt version used to compile PySide" FORCE)
include(${QT_USE_FILE})
if (${QTVERSION} VERSION_LESS 4.5.0)