aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAnderson Lizardo <anderson.lizardo@openbossa.org>2010-08-13 22:32:07 -0400
committerAnderson Lizardo <anderson.lizardo@openbossa.org>2010-08-26 11:04:58 -0400
commit3c36d444729ee9285bb4ab0252968057bf904a8d (patch)
treebc5790e5afa2bf2cf1589b7f2fd182f471e4bbee /CMakeLists.txt
parent2593f9fccc71a200c5a802b2e05717910885e864 (diff)
Various cleanups to CMakeLists.txt files
* Simplify endmacro(), endif() and else() statements * Remove unused and redundant code * Use AUTO_OS for holding the typesystem suffix (instead of MODULE_NAME) Reviewed-by: Luciano Wolf <luciano.wolf@openbossa.org> Reviewed-by: Hugo Parente Lima <hugo.lima@openbossa.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt17
1 files changed, 7 insertions, 10 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3f5dc7e07..244e5586a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -72,25 +72,22 @@ if (${QTVERSION} VERSION_LESS 4.5.0)
endif()
# Configure OS support
+set(ENABLE_X11 "0")
+set(ENABLE_MAC "0")
+set(ENABLE_WIN "0")
if(Q_WS_X11)
set(ENABLE_X11 "1")
- set(ENABLE_MAC "0")
- set(ENABLE_WIN "0")
if(Q_WS_MAEMO_5)
- set(AUTO_OS "MAEMO 5")
+ set(AUTO_OS "maemo")
else()
- set(AUTO_OS "X11")
+ set(AUTO_OS "x11")
endif()
elseif(Q_WS_MAC)
- set(ENABLE_X11 "0")
set(ENABLE_MAC "1")
- set(ENABLE_WIN "0")
- set(AUTO_OS "MAC")
+ set(AUTO_OS "mac")
elseif(Q_WS_WIN)
- set(ENABLE_X11 "0")
- set(ENABLE_MAC "0")
set(ENABLE_WIN "1")
- set(AUTO_OS "WIN")
+ set(AUTO_OS "win")
else()
message(FATAL_ERROR "OS not supported")
endif()