aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorHugo Lima <hugo.lima@openbossa.org>2009-10-19 11:13:01 -0200
committerLuciano Miguel Wolf <luciano.wolf@indt.org.br>2009-10-21 16:34:20 -0300
commit72c050930eeb69c5d436ec6ad7ffc6a1a20211ed (patch)
treec4f5dd71f7e322e4e34278dee099f64ca3c1a048 /CMakeLists.txt
parent4b881a93bba85821e4cc5afb4e247fe141677389 (diff)
Removed code that always add _d as debug postfix, debug postfix is usefull for some packagers
but awful for other distros or simple raw builds, because debug libs will be generated with a difenrent name and all other projects are expecting the library name without the debug postfix, resulting in a linker error, because the library was not found. For all packagers that still want to set a debug postfix, just use the cmake flag: -DCMAKE_DEBUG_POSTFIX:STRING="my_debug_postfix"
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 1 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c73580f49..08eee62e9 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -58,7 +58,6 @@ parser/rpp/pp-main.cpp
parser/rpp/preprocessor.cpp
)
-set(LIB_DEBUG_POSTFIX "_d" CACHE STRING "Define postfix used in debug library name")
set(LIB_INSTALL_DIR "${CMAKE_INSTALL_PREFIX}/lib${LIB_SUFFIX}" CACHE PATH "The subdirectory relative to the install prefix where libraries will be installed (default is /lib${LIB_SUFFIX})" FORCE)
qt4_add_resources(apiextractor_RCCS_SRC generator.qrc)
@@ -75,9 +74,7 @@ include_directories(${CMAKE_CURRENT_SOURCE_DIR}
add_library(apiextractor SHARED ${apiextractor_SRC} ${apiextractor_RCCS_SRC})
target_link_libraries(apiextractor ${LIBXSLT_LIBRARIES} ${LIBXML2_LIBRARIES} ${QT_QTCORE_LIBRARY} ${QT_QTXMLPATTERNS_LIBRARY} ${QT_QTXML_LIBRARY})
-set_target_properties(apiextractor PROPERTIES
- VERSION ${apiextractor_VERSION} SOVERSION ${apiextractor_MAJOR_VERSION}
- DEBUG_POSTFIX ${LIB_DEBUG_POSTFIX})
+set_target_properties(apiextractor PROPERTIES VERSION ${apiextractor_VERSION} SOVERSION ${apiextractor_MAJOR_VERSION})
# create pkg-config file
configure_file(${CMAKE_CURRENT_SOURCE_DIR}/apiextractor.pc.in