aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorHugo Lima <hugo.lima@openbossa.org>2009-12-15 19:24:30 -0200
committerHugo Lima <hugo.lima@openbossa.org>2009-12-16 15:02:42 -0200
commitc8e908097207d8852e17e99585ae88a17e3af144 (patch)
treed9aaf4d99ad3711654c98ef5ae6af8da2d4b9e9f /CMakeLists.txt
parentd90b6ba47409c7cc461bb6c200f8e41b9a917088 (diff)
Initial port of signal slots infrastructure from PySide to the Shiboken version.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index fb6958134..cb78ea0e5 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -59,10 +59,11 @@ if (NOT SITE_PACKAGE)
message(FATAL_ERROR "Could not detect Python module installation directory.")
endif (NOT SITE_PACKAGE)
-set(GENERATOR_EXTRA_FLAGS --generatorSet=shiboken --enable-parent-ctor-heuristic)
+set(GENERATOR_EXTRA_FLAGS --generatorSet=shiboken --enable-parent-ctor-heuristic --enable-pyside-extensions)
enable_testing()
+add_subdirectory(libpyside)
# project directories
add_subdirectory(${BINDING_NAME})
add_subdirectory(tests)