aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorRenato Filho <renato.filho@openbossa.org>2010-05-21 20:18:41 -0300
committerRenato Filho <renato.filho@openbossa.org>2010-05-24 10:24:41 -0300
commitc2b2e579ae58562e620224e1b82cd199edab248b (patch)
treece480f816d76d19ea142b4d9243aa3d24378050a /CMakeLists.txt
parentca4279fb792eda7cd34e8e36a248dadcf93e87dd (diff)
Updated QtNetwork typesystem to support Qt 4.7
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 7 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5c686246c..02ac03655 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -73,9 +73,15 @@ elseif(Q_WS_WIN)
else()
message(FATAL_ERROR "OS not supported")
endif()
-
message(STATUS "Detected OS: ${AUTO_OS}")
+# Define supported Qt Version
+if(${QT_VERSION_MAJOR} EQUAL 4 AND ${QT_VERSION_MINOR} GREATER 6)
+ set(SUPPORTED_QT_VERSION 4.7)
+else()
+ set(SUPPORTED_QT_VERSION 4.6)
+endif()
+
set(BINDING_VERSION ${BINDING_API_VERSION}.${QT_VERSION_MAJOR}.${QT_VERSION_MINOR})
find_program(GENERATOR generatorrunner REQUIRED)