aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorHugo Parente Lima <hugo.pl@gmail.com>2010-08-18 16:02:14 -0300
committerHugo Parente Lima <hugo.pl@gmail.com>2010-08-18 16:42:35 -0300
commit1b89ed5df330e4588838de36a7bbf11e595158e2 (patch)
tree6af2cbcf5f1cdaf60d56d4ceb9daf70fbd932b3b /CMakeLists.txt
parent876afa44660e1275358cfe05f649bb34c250c460 (diff)
Don't *always* build generatorrunner as debug.
This fixes the segfault under windows when compiling in release mode. Reviewer: Luciano Wolf <luciano.wolf@openbossa.org> Renato Araújo <renato.filho@openbossa.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 1 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 6b1dca18b..a2ba54a60 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -8,7 +8,7 @@ find_package(ApiExtractor 0.7 REQUIRED)
option(BUILD_TESTS "Build tests." TRUE)
if(MSVC)
- set(CMAKE_CXX_FLAGS "/Zc:wchar_t- /EHsc /DWIN32 /D_WINDOWS /DGENRUNNER_BUILD -D_SCL_SECURE_NO_WARNINGS")
+ set(CMAKE_CXX_FLAGS "/Zc:wchar_t- /EHsc /DWIN32 /D_WINDOWS /DGENRUNNER_BUILD /D_SCL_SECURE_NO_WARNINGS")
elseif(CMAKE_HOST_UNIX)
option(ENABLE_GCC_OPTIMIZATION "Enable specific GCC flags to optimize library size and performance. Only available on Release Mode" 0)
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wall -fvisibility=hidden")
@@ -44,8 +44,6 @@ add_definitions(${QT_DEFINITIONS})
configure_file(generatorrunnerconfig.h.in "${CMAKE_CURRENT_BINARY_DIR}/generatorrunnerconfig.h" @ONLY)
-set(CMAKE_BUILD_TYPE Debug)
-
include_directories(${CMAKE_CURRENT_SOURCE_DIR}
${CMAKE_CURRENT_BINARY_DIR}
${APIEXTRACTOR_INCLUDE_DIR}