aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorChris Hills <chaz@chaz6.com>2009-08-31 19:19:01 +0200
committerHugo Lima <hugo.lima@openbossa.org>2009-08-31 17:17:39 -0300
commit267d9adb4f6e19b3c314a501f84d8fae22c0983c (patch)
treea462924bd3bec14b3b868d70d53bfad10f39d073 /CMakeLists.txt
parent06b1408262174c6bbfc4113f2c68fa692f19def3 (diff)
Add pkg-config and cmake support
Reviewed by Hugo Parente
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a64c3b859..4e7bcb7d7 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -37,6 +37,12 @@ target_link_libraries(generatorrunner
${APIEXTRACTOR_LIBRARY}
${QT_QTCORE_LIBRARY})
+# create pkg-config file
+configure_file(${CMAKE_CURRENT_SOURCE_DIR}/generatorrunner.pc.in
+ ${CMAKE_CURRENT_BINARY_DIR}/generatorrunner.pc @ONLY)
+configure_file(${CMAKE_CURRENT_SOURCE_DIR}/FindGeneratorRunner.cmake.in
+ ${CMAKE_CURRENT_BINARY_DIR}/FindGeneratorRunner.cmake @ONLY)
+
# uninstall target
configure_file("${CMAKE_CURRENT_SOURCE_DIR}/cmake_uninstall.cmake"
"${CMAKE_CURRENT_BINARY_DIR}/cmake_uninstall.cmake"
@@ -55,6 +61,10 @@ add_custom_target(dist
install(TARGETS genrunner DESTINATION ${LIB_INSTALL_DIR})
install(TARGETS generatorrunner DESTINATION bin)
install(FILES generator.h DESTINATION include/generatorrunner)
+install(FILES ${CMAKE_CURRENT_BINARY_DIR}/generatorrunner.pc DESTINATION
+ ${LIB_INSTALL_DIR}/pkgconfig)
+install(FILES ${CMAKE_CURRENT_BINARY_DIR}/FindGeneratorRunner.cmake
+ DESTINATION share/cmake-2.6/Modules)
enable_testing()