aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAnderson Lizardo <anderson.lizardo@openbossa.org>2010-08-13 22:38:54 -0400
committerAnderson Lizardo <anderson.lizardo@openbossa.org>2010-08-26 11:07:11 -0400
commit6914f21603fa32727af0d419b6f438e88413ed7f (patch)
treecd1ae9ad6372f7d23ba724965b395895e19f5fa0 /CMakeLists.txt
parente5e44b6465e2755c70c8e13060de4c2ca799fd64 (diff)
Add Qt Simulator support
Reviewed-by: Luciano Wolf <luciano.wolf@openbossa.org> Reviewed-by: Hugo Parente Lima <hugo.lima@openbossa.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 244e5586a..c62fdf9f4 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -75,6 +75,7 @@ endif()
set(ENABLE_X11 "0")
set(ENABLE_MAC "0")
set(ENABLE_WIN "0")
+set(ENABLE_SIMULATOR "0")
if(Q_WS_X11)
set(ENABLE_X11 "1")
if(Q_WS_MAEMO_5)
@@ -88,6 +89,9 @@ elseif(Q_WS_MAC)
elseif(Q_WS_WIN)
set(ENABLE_WIN "1")
set(AUTO_OS "win")
+elseif(Q_WS_SIMULATOR)
+ set(ENABLE_SIMULATOR "1")
+ set(AUTO_OS "simulator")
else()
message(FATAL_ERROR "OS not supported")
endif()