aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorHugo Parente Lima <hugo.pl@gmail.com>2010-08-11 13:07:47 -0300
committerHugo Parente Lima <hugo.pl@gmail.com>2010-08-11 15:45:58 -0300
commitecfb5f1a7508cef02789363446c66bacf02ce3fa (patch)
treec0d4f8584352815364b2cfb2ebe7e3d2702cb611 /CMakeLists.txt
parent6485031031d546abbec2b761546e7ed3eb3e1ff1 (diff)
Fix debug build when no debug symbols was found for Python libs.
Reviewer: Luciano Wolf <luciano.wolf@openbossa.org> Renato Araújo <renato.filho@openbossa.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 98a007de3..d698696b5 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -92,8 +92,9 @@ if(CMAKE_BUILD_TYPE STREQUAL "Debug")
endif()
if(NOT PY_DEBUG)
message(WARNING "Compiling shiboken with debug enabled, but the python executable was not compiled with debug support.")
+ else()
+ add_definitions("-DPy_DEBUG")
endif()
- add_definitions("-DPy_DEBUG")
set(SBK_PYTHON_LIBRARIES ${PYTHON_DEBUG_LIBRARIES})
else()
set(SBK_PYTHON_LIBRARIES ${PYTHON_LIBRARIES})