aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMarcelo Lira <marcelo.lira@openbossa.org>2010-08-13 14:15:52 -0300
committerMarcelo Lira <marcelo.lira@openbossa.org>2010-08-13 14:42:55 -0300
commit2b21d79f5439d982de2495d3a190c4f82f51e458 (patch)
tree9fa0dcd7d5ffd64e67a3114b741255d617d43273 /CMakeLists.txt
parent8ea5127ccbb0a5d84313041559769bc40fc2ad67 (diff)
All tests using GUI aren't shown if the host machine has xvfb installed.
Unwanted graphical output from tests are redirected to a fake X server on Unix system. This depends on the presence of the Xvfb server. Reviewed by Hugo Parente <hugo.lima@openbossa.org> Reviewed by Luciano Wolf <luciano.wolf@openbossa.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b75d1f9cf..dd6b863a7 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -10,6 +10,13 @@ find_package(PythonInterpWithDebug REQUIRED)
find_package(Shiboken 0.4.0 REQUIRED)
find_package(Qt4 4.5.0 REQUIRED)
+find_program(XVFB_RUN NAMES xvfb-run)
+set(XVFB_EXEC "")
+if (NOT ${XVFB_RUN} MATCHES "XVFB_RUN-NOTFOUND")
+ set(XVFB_EXEC ${XVFB_RUN})
+ message("Using xvfb-run to perform QtGui tests.")
+endif()
+
set(LIB_SUFFIX "" CACHE STRING "Define suffix of directory name (32/64)" )
set(LIB_INSTALL_DIR "${CMAKE_INSTALL_PREFIX}/lib${LIB_SUFFIX}" CACHE PATH "The subdirectory relative to the install prefix where libraries will be installed (default is /lib${LIB_SUFFIX})" FORCE)
if(CMAKE_HOST_APPLE)