aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorHugo Parente Lima <hugo.pl@gmail.com>2010-09-24 15:34:20 -0300
committerHugo Parente Lima <hugo.pl@gmail.com>2010-09-24 16:12:05 -0300
commit3e0af488ee5820f35462f381c5a1676dc9560a5d (patch)
treec628028c0c85c32d2f3afbf779203a4331b205ee /CMakeLists.txt
parent9eddff59405f9bfb94c0bb15da3d047eb7029958 (diff)
Fix bug#168 - "API documentation suggestions" and other fixes.
Reviewer: Luciano Wolf <luciano.wolf@openbossa.org> Marcelo Lira <marcelo.lira@openbossa.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 8 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 47ab784fa..5c50500ad 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -179,6 +179,12 @@ enable_testing()
add_subdirectory(libpyside)
# project directories
-add_subdirectory(${BINDING_NAME})
+add_subdirectory(PySide)
add_subdirectory(tests)
-add_subdirectory(doc)
+
+find_program(DOT_EXEC dot)
+if (QT_SRC_DIR AND DOT_EXEC)
+ add_subdirectory(doc)
+else ()
+ message(STATUS "QT_SRC_DIR variable not set or graphviz not found, apidoc generation targets disabled.")
+endif()