aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMarcelo Lira <marcelo.lira@openbossa.org>2010-10-25 18:23:03 -0300
committerMarcelo Lira <marcelo.lira@openbossa.org>2010-10-26 13:49:07 -0300
commitb0e9403d48c4c7a21ae8d7e2eaf26d712a835556 (patch)
treed5192f64d29aac834f67eac962ce696d204f7fd3 /CMakeLists.txt
parent720c76980dedd51abee7f182bd261a9ce5405a5e (diff)
Updated PySide cmake files to use Python library information from Shiboken.
Shiboken cmake files provides information about which Python library to link against through cmake SHIBOKEN_PYTHON_LIBRARIES variable. It also sets the Py_DEBUG flag if necessary. Reviewed by Lauro Moura <lauro.neto@openbossa.org> Reviewed by Renato Araujo <renato.filho@openbossa.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 0 insertions, 10 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e148c2a66..fc7c37d14 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -151,16 +151,6 @@ if (NOT SITE_PACKAGE)
endif()
endif()
-if(SHIBOKEN_BUILD_TYPE STREQUAL "Debug")
- add_definitions("-DPy_DEBUG")
- set(PYSIDE_PYTHON_LIBRARIES ${PYTHON_DEBUG_LIBRARIES})
-else()
- set(PYSIDE_PYTHON_LIBRARIES ${PYTHON_LIBRARIES})
-endif()
-if(APPLE)
- set(PYSIDE_PYTHON_LIBRARIES "-undefined dynamic_lookup")
-endif()
-
set(GENERATOR_EXTRA_FLAGS --generatorSet=shiboken --enable-parent-ctor-heuristic --enable-pyside-extensions --enable-return-value-heuristic)
enable_testing()