aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorrenatofilho <renato.filho@openbossa.org>2010-10-07 15:12:57 -0300
committerrenatofilho <renato.filho@openbossa.org>2010-10-07 16:35:32 -0300
commite8e8da9efdcb728dd1989d9274cbc22be22ae9c4 (patch)
tree771d5ad81294d0c7601361792e683d46af24b553 /CMakeLists.txt
parent897dd874a34ddfc164ea7dbd4bfd5eaffd02aabd (diff)
Only compile QtUiLoader if QTDesigner was found.
Reviewer: Hugo Parente Lima <hugo.pl@gmail.com> Luciano Wolf <luciano.wolf@openbossa.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index db5ca01e1..5613f5242 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -183,7 +183,9 @@ set(GENERATOR_EXTRA_FLAGS --generatorSet=shiboken --enable-parent-ctor-heuristic
enable_testing()
add_subdirectory(libpyside)
-add_subdirectory(plugins)
+if(QT_QTDESIGNER_FOUND)
+ add_subdirectory(plugins)
+endif()
# project directories
add_subdirectory(PySide)
add_subdirectory(tests)