aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorLauro Neto <lauro.neto@openbossa.org>2009-08-19 10:43:18 -0300
committerLauro Neto <lauro.neto@openbossa.org>2009-08-19 10:43:18 -0300
commit4fca5b868e8b3d982dfa2ceb95806b2a5b2bb639 (patch)
tree8dab2f5b4db92438e5d1ffe75cf147fdd063a46e /CMakeLists.txt
parent0a3ae6f6ace1da4720ccf9e70a56e279087f0018 (diff)
Adding 'make dist' with git-archive
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt14
1 files changed, 10 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 7de679e14..5e385494f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -43,10 +43,16 @@ add_custom_target(uninstall "${CMAKE_COMMAND}"
# "make dist", in fact "make package_source"
-set(CPACK_SOURCE_PACKAGE_FILE_NAME "boostpythongenerator-${boostpythongenerator_VERSION}")
-set(CPACK_SOURCE_GENERATOR TGZ)
-set(CPACK_SOURCE_IGNORE_FILES "~$" ".svn" "debian/" "build/" ".swp$" "*.kdev4")
-include(CPack)
+#set(CPACK_SOURCE_PACKAGE_FILE_NAME "boostpythongenerator-${boostpythongenerator_VERSION}")
+#set(CPACK_SOURCE_GENERATOR TGZ)
+#set(CPACK_SOURCE_IGNORE_FILES "~$" ".svn" "debian/" "build/" ".swp$" "*.kdev4")
+#include(CPack)
+
+set(ARCHIVE_NAME ${CMAKE_PROJECT_NAME}-${boostpythongenerator_VERSION})
+add_custom_target(dist
+ COMMAND git archive --prefix=${ARCHIVE_NAME}/ HEAD
+ | bzip2 > ${CMAKE_BINARY_DIR}/${ARCHIVE_NAME}.tar.bz2
+ WORKING_DIRECTORY ${CMAKE_SOURCE_DIR})
install(TARGETS boostpythongenerator DESTINATION bin)